Symptom:
- You have completed the sign-up process for Financio Payroll but there is no confirmation email reaching your inbox.
Root cause:
You may proceed to check the below possible reasons that can cause the email not reaching you:
- Incorrect Email address – please ensure that the email address that you entered during sign-up is a valid email address, small typo mistake could have also caused this issue.
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- Emails are marked as SPAM - Email could be sitting under junk or spam folder of your mailbox, you may first search from the particular folder.
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- Email could have been sent to a group email address - if you sign up using a group email address such as HR@ then it’s possible the email could have been sent there, rather than to your personal inbox.
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- Outlook Setting - You should check that you don’t have any Outlook rules setting that might be moving the email to other folder or blocking the email or quarantining it. Please consult your IT admin if you have a company email server that controls the incoming email.
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